Lors du passage de mysql-server-5.032 à mysql-server-5.038-1, la procédure d'installation (en fait un apt-get upgrade) s'est bloquée à ce niveau :

Setting up mysql-server-5.0 (5.0.38-1) ...
Stopping MySQL database server: mysqld.

Après moulte recherche, il s'avère que c'était un problème de version de noyau. En effet, depuis la version 5.036, le serveur mysql a besoin d'un noyau 2.6, or j'étais en 2.4 depuis des lustres.

MySQL Bugs: #27714: mysql_install_db fails with kernel 2.4