Le TwiBlog

The one with Twidi

Aller au contenu | Aller au menu | Aller à la recherche

lundi 23 avril 2007

Kubuntu : problème lors du passage de Edgy à Feisty (le "Kubuntu upgrade tool" ne s'ouvre pas)

En utilisant la procédure recommandée pour passer mon Kubuntu de Edgy au tout nouveau Feisty, j'ai eu un problème, que j'évoque ici afin de donner la solution.

Il est donc recommandé d'utiliser Adept Manager, de faire un "Fetch update", et que de là, un assistant va s'ouvrir. Jusque là tout va bien.

Cet assistant se termine par un clic sur un bouton "finish" à partir duquel est normalement censé s'ouvrir le "Kubuntu upgrade tool". Sauf que celui ne s'ouvrait pas.

Pour que cet outil de mise à jour s'ouvre, il faut deux conditions :

- TOUS les paquets doivent être à jour (j'avais un problème ave mon opera qui demandait une version de libc que je n'avais pas, solution : apt-get remove opera)

- TOUS les dépôts contenus dans /etc/apt/sources.list doivent être bon (ils doivent répondre et ne pas avoir de problème de clé), si un ne répond pas, il suffit de le commenter (en rajoutant un # devant)

Une fois ces petits problèmes résolus, l'upgrade se passe bien (téléchargement de 1004Mo en cours pour moi)

Mysql 5 (5.036, 5.038 et suivant) : l'installation échoue en cas de noyau 2.4

Lors du passage de mysql-server-5.032 à mysql-server-5.038-1, la procédure d'installation (en fait un apt-get upgrade) s'est bloquée à ce niveau :

Setting up mysql-server-5.0 (5.0.38-1) ...
Stopping MySQL database server: mysqld.

Après moulte recherche, il s'avère que c'était un problème de version de noyau. En effet, depuis la version 5.036, le serveur mysql a besoin d'un noyau 2.6, or j'étais en 2.4 depuis des lustres.

MySQL Bugs: #27714: mysql_install_db fails with kernel 2.4